2010

1/13/10 – when running ITIM 5.1 upgrade from 5.0, get this on dbUpgrade
sqlcode=-552, sqlstate=42502
– was because used root to configure the db.  Needed to use db inst owner

1/13/10 30906 379 – when installing 5.1 fp1 using update installer 7.0.0.0, fp1 shows as not applicable
– also could not create a person
– problem: WAS was installed with cluster
– uninstalled WAS, installed as single-server, applied fp5, installed updinstlr 7.0.0.7
– still got jms errors
– itim_bus was unavailable
– followed step 5 and on in http://www.ibm.com/support/docview.wss?uid=swg21380384
– restarted WAS
– was able to create a person
– attempted itim upgrade to 5.1 fp1 – could not recognize fixpack
– was pointing to was for upgrade, pointed to /opt/IBM/itim, saw fixpack, retried
– got error CWUPI0013E: A configuration action failed. The failing configuration action is: UpdateITIMEar.
– found error 105 in ant script in /opt/IBM/itim/logs/update/5.1.0.1-TIV-TIM-FP0001/updateconfig.log
– in soap.client.props file, was_profiel\properties changed com.ibm.SOAP.requestTimeout=1200
– retried upgrade, worked
– doc APARs/APAR needed

1/27/10 32903 379 – CTGIMA416E The following process cannot be found in the database.
Process ID: 7835357467799461128

1/29/10  when installing WAS 7.0 cluster member, got errror:
com.ibm.ws.install.ni.ismp.installtoolkitbridge.ISMPInstallToolkitBridgeForNIFramework,
wrn, Config action failed: 97SInstallInvokeWSProfile – /usr/IBM/WebSphere/AppServer/properties/version/nif/config/install/97S
InstallInvokeWSProfile.ijc
– manually tried federating the node
./addNode.sh hostname 8879
– time was not sync’d between servers, sync’d time
– federated node, worked
– until ITIM wouldn’t install on the node – had to reinstall WAS

– this was running on 02:
root 512014 626844   2 10:46:44  pts/1  1:10 /usr/IBM/WebSphere/AppServer/java/bin/java -Xbootclasspath/p: -Dws.output.encoding=console -Dosgi.install.area=/usr/IBM/WebSphere/AppServer -Dosgi.configuration.area=/usr/IBM/WebSphere/AppServer/profiles/Custom01/configuration -Dcom.ibm.CORBA.ConfigURL=file:/usr/IBM/WebSphere/AppServer/profiles/Custom01/properties/sas.client.props -Dcom.ibm.SSL.ConfigURL=file:/usr/IBM/WebSphere/AppServer/profiles/Custom01/properties/ssl.client.props -Dcom.ibm.SOAP.ConfigURL=file:/usr/IBM/WebSphere/AppServer/profiles/Custom01/properties/soap.client.props -Djava.security.auth.login.config=/usr/IBM/WebSphere/AppServer/profiles/Custom01/properties/wsjaas_client.conf -Dcom.ibm.ws.scripting.wsadminprops=/usr/IBM/WebSphere/AppServer/profiles/Custom01/properties/wsadmin.properties -Dconfig_consistency_check= -Dwas.install.root=/usr/IBM/WebSphere/AppServer -Duser.install.root=/usr/IBM/WebSphere/AppServer/profiles/Custom01 -Dwas.repository.root=/usr/IBM/WebSphere/AppServer/profiles/Custom01/config -Dlocal.cell=hdgisscwctmq2Node01Cell -Dlocal.node=hdgisscwctmq2Node01 -Dcom.ibm.ws.management.standalone=true -Dcom.ibm.itp.location=/usr/IBM/WebSphere/AppServer/bin -Dws.ext.dirs=/usr/IBM/WebSphere/AppServer/java/lib:/usr/IBM/WebSphere/AppServer/classes:/usr/IBM/WebSphere/AppServer/lib:/usr/IBM/WebSphere/AppServer/installedChannels:/usr/IBM/WebSphere/AppServer/lib/ext:/usr/IBM/WebSphere/AppServer/web/help:/usr/IBM/WebSphere/AppServer/deploytool/itp/plugins/com.ibm.etools.ejbdeploy/runtime -Xms256m -Xmx256m -Xquickstart -Djava.util.logging.manager=com.ibm.ws.bootstrap.WsLogManager -Djava.util.logging.configureByServer=true -classpath /usr/IBM/WebSphere/AppServer/profiles/Custom01/properties:/usr/IBM/WebSphere/AppServer/properties:/usr/IBM/WebSphere/AppServer/lib/startup.jar:/usr/IBM/WebSphere/AppServer/lib/bootstrap.jar:/usr/IBM/WebSphere/AppServer/lib/lmproxy.jar:/usr/IBM/WebSphere/AppServer/lib/urlprotocols.jar:/usr/IBM/WebSphere/AppServer/java/lib/tools.jar:/usr/IBM/WebSphere/AppServer/deploytool/itp/batchboot.jar:/usr/IBM/WebSphere/AppServer/deploytool/itp/batch2.jar com.ibm.wsspi.bootstrap.WSPreLauncher -nosplash -application com.ibm.ws.bootstrap.WSLauncher com.ibm.ws.runtime.WsProfileAdminListener /usr/IBM/WebSphere/AppServer/profiles/Custom01/temp/wsadmin /usr/IBM/WebSphere/AppServer/logs/manageprofiles/Custom01/wsadminListener.log ISO8859-1

2/1/10 – 33658 379  ITIM 5.1 upgrade does not work on a cluster if you use a cluster name other than the default name listed as the example in the install doc (ITIM_Application_Cluster)  Used itim_app_cluster and itim_msg_cluster.  Install does not prompt for cluster names.  Got WasClusterConfigUtil.updateJvmPath failed and other errors
– had to change cluster name in runConfig.lax, worked on DM
– then was problem on cluster member – could not find WAS profile
– was APP_SERVER_HOME=/usr/IBM/WebSphere/AppServer/profiles/AppSrv01
– which didn’t exist.  changed to:
– APP_SERVER_HOME=/usr/IBM/WebSphere/AppServer/profiles/Custom01
– same error
– previous error installing on invoking the profile is issue
– uninstalled, reinstalled, same error in install log.txt
– tried deleting profile, could not find profile
– deleted profile dir, tried creating profile, hung on importWasprofile
– uninstalled WAS, ran ./installRegistryUtils.sh -cleanAll
– installed WAS 7.0, ITIM upgrade worked, closed

2/4/10 – messaging engines were unavailable on cluster upgrade to 5.1
– DBconfig had not been run successfully
– on runConfig install, was getting itim_bus already exists
– Once getting DB comm to work, DBA had dropped enrole tables but not sib tables
– had to remove ITIM from WAS manually, including itim_bus, drop enrole and sib tables, run ITIM install on both nodes, started WAS, worked

2/4/10 – 34355 379 – Logging on with bad user id/pwd gives 500 null pointer exception
Gary – 714-327-5916
– nothing in trace.log or access.log
Can you please perform a diff of the contents of the ITIM.ear file in the installedApps directory on your working vs. non-working system?  Can you also provide a copy of the ui.properties file from the working and non-working system as well as a copy of the enRole.properties file from both systems.
– sent
– asked to send msg, trace, sysout syserr, ffdc logs at MIN setting
– also noticed that server is not stop/startable from WAS console
– Installed fixpack 7, resolved issue, closed

2/4/10 – 34372 379 – IDI Feed fails to Create Person in ITIM5.1
changes filter to (|(namingcontexts=dc=FromIL))(ernamingcontexts=dc=FromIL)))
– format of $dn was incorrect – don’t use parens – just uid=…
– worked, closed

2/10/10 – 45214 379 – Err upgrading 5.1 to fp1 – DBUpgrade fails
JPanelRdbmsConfig.JPanelRdbmsConfig: For upgrade, change button text from ‘Test’ to ‘Continue’, then
reset the action command back to ‘Test’.
– Chris Weber
– Tried running DBConfig, dropping tables, fails on enrole.menu, manually dropped enrole and sib tables
– Reran DBConfig, created/configed tables
– Retried fp1 upgrade, same error
– created <itim home>/properties/version/nif/config/install/backdoors_user.properties file, having the following entry:  skip.dbupgrade=true
– reran install, worked
– removed backdoor, tried upgrading with UpdInst 7005, worked fine
– Manqing Li/Ottawa   developer

2/25/10 – 47431 379 – haven’t sync’d password yet, user gets locked out, call help desk
first try to reset the password,
itim account is “inactive”, it doesn’t reset password for inactive account
TAM/iSeries works; ITIM/SAP doesn’t
– if hd does a restore, then pwd change, then works
– Charles S

3/11/10 – 77896 344 – after migrating from 4.6-5.1, cannot view adoption policies

3/11/10 – 77900 344 – Unable to View/Edit Password Policies in 5.1
CTGIMU116E  An error occurred while retrieving the services covered by the password policy                  CTGIMG012E  An error occurred while retrieving detailed information of the service

3/12/10 – 77016 344 – workflows
– inconsistent case in dc=sem/dc=SEM
– Mike C supplied perl script to fix case

3/16/10 – when installing IDS 6.2, get glpins253e – no features available for installation
– uninstall didn’t uninstall

3/16/10 – 78138 344 cannot remove IDS instance.  dropped database, and database instance, deleted home
– lists of instances are in __cfg

3/17/10 – 78241 344 getting “no Memory” on bulkload
– issue was currupted ldif

3/18/10 – delete pending transactions from database – clear database
http://www.ibm.com/support/docview.wss?uid=swg21380384

3/19/10 – 78320 344 – when trying to logon to itim, got “an error has occurred”
getting NameNotFoundException: dnqualifier, in trace.log
– cause was recert policy
was getting in ibmslapd.log – GLPSRV204W The server has temporarily suspended reading client requests from the network 10 times. There are 0 of 15 worker threads attempting to write results
– tried to run ldapsearch on ou=people, and got out of memory error
– had set entry cache to 500000, set it back to 25000, same problem
– set ulimits for root and ldap owner to unlimited for mem and data, 2097151 for stack, worked

4/9/10 – When calling dll from ITDI getting: CTGDIS628E Error in COMProxy.dll: IDispatch not initialized

4/14/10 – 79130 7TD – help with itdi script

var oh;
var ohi;
var nh;
oh = conn.getAttribute(“handle”);
system.dumpentry;
nh = oh + 0;
ret.value = nh;

4/15/10 – 79321 7TD – getting schema violation importing custom adapter profile
– when moving connector to flow, where it needs to be to work and not give null value for query

4/16/10 – 79361 7TD – attrib not avail in output map when using branch or loop

4/19/10 – 26323 499 – sev1 – During Feed, getting Transaction rollback
– WAS won’t start clean w/o XA exceptions
– stopped WAS, ran removeTransactions.sh, cleaned tranlogs, restarted WAS
– still got XA Exceptions, and had 600 in Pending
– Deleted all Pending trans
– found /db2itim_ind1 was 98% used (indexes)
– ran removeTransactions.sh, cleaned tranlogs, restarted WAS
– still got XA Exceptions
979-942-8178 Clyde cell
– comitted indoubt transactions (pmr 26534), repeated above, no XA exceptions!
– XA exceptions returned when transaction logs filled up
– added more trans logs, cleared sib and partner logs, still had indoubt trans
– chose forget on all 5 indoubt trans,
-db2 tranlogs were read in and archived properly, relieving space
– closed

4/20/10 – 26534 499 – sev1 – cannot release lock on scheduled_message table -> DB2
db2 list indoubt transactions with prompting
– all were status “i” – were 5 transactions – committed all 5, quit
– db2 restart db
– after purging SIB was able to start WAS clean
– indoubt trans still existed
– forget transactions was the resolution, closed

4/28/10 – 26206 499 – Cannot make salesman number searchable – search fields have to be text not numeric
– working as designed
– Brian will work with Fernando

4/28/10 – 27212 499 – Recons running 8-18 hours after scheduled
– Can check these tables to see if it’s hitting the limit for recons or a resource is marked down:
RESOURCE_PROVIDERS table, REMOTE_SERVICES_REQUESTS table, ACTIVITY table
http://www-01.ibm.com/support/docview.wss?rs=644&tcss=Newsletter&uid=swg21380983

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

w

Connecting to %s


%d bloggers like this: